38 C
Dubai
Wednesday, August 17, 2022
spot_img

How to install / Configure Blackberry Enterprise Server 5.0.4 MR2 with Exchange 2013 – Part 2

Download the BesUpdate by Contacting Blackberry Support or  get it from the below link.

I got this update from a Forum

https://www.dropbox.com/s/w6dmjvfqb9reprx/BESUPDATE.zip

 

Reference Link :

http://supportforums.blackberry.com/t5/BlackBerry-Professional-Software/Exchange-2013-KB-Article-Says-Contact-Support/td-p/2254555

 

For this Task – Login as administrator

Open Services.msc.

Stop BlackBerry Dispatcher service

Locate –

C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server

Take a Backup of it.

image

BlackBerryAgent.exe

CalHelper.exe

CalHelperWS.exe

EWS.dll

Now replace the Updated files in the installation location

now Use Trait Tool to Enable Exchange Web services to be used

Open Command Prompt :

Locate :

“C:\Research In Motion\BlackBerry Enterprise Server 5.0.4\bundle0038\tools”
image

Now Restart Bes Server.

Now Activate Blackberry for a User - 

To Verify things are fine .
Locate Command Prompt to below location - C:\Program Files (x86)\Research In Motion\BlackBerry Enterprise Server\Utility>
image
Choose Outlook Profile
image
Add the User you want to Test
image


image

If things fails you Can try adding Mailbox - 
To Verify AD permission
get-mailboxserver | get-ADpermission -user besadmin | Format-List
To ADD AD permission
get-mailboxserver | add-adpermission -user besadmin -accessrights GenericRead, GenericWrite -extendedrights Send-As, Receive-As, ms-Exch-Store-Admin

Smile

 

 

Now things should work Smile

 

 

 

 

 

 

 

 

 

 

Satheshwaran Manoharan
Satheshwaran Manoharanhttps://www.azure365pro.com
Specialized in Microsoft Azure - Office 365 / Microsoft Exchange; conducted numerous projects worldwide in designing, supporting, and implementing messaging and virtualization infrastructure for medium-sized and large enterprises. Further, I am a Cloud Architect and Technical Advisor for various start-ups.

Related Articles

2 COMMENTS

  1. Hi,

    I tested this solution and even gave permisions to all the right users. However now i cannot add a device i get error code 8004011d from the IEMSTest.exe

  2. Same problem here….. I followed BES manual for exchange 2010 cause there is no official manual for 2013 and then found your well documented article but I can’t solve that error. I hate this BES shit….

LEAVE A REPLY

Please enter your comment!
Please enter your name here