Saturday , April 4 2020

Exchange Server couldn’t find Enterprise Organization Container

Customers who did cutover or migrated their mailboxes to the cloud removed all the exchange servers environment then they think about bringing a new exchange server later point of time may end up with this error and there are some left over objects in the Active Directory environment. They quickest solution we found is to check which exchange server version was there in the environment lastly. Run PrepareAD with that setup once and re run the exchange server 2016 setup. Then the setup worked seamlessly. In my case the last exchange server was 2010. so ran preparead with exchange 2010

First Ran Exchange Server 2016 _ Error _

Couldn’t find the Enterprise Organization container.

clip_image001

Error:
A reboot from a previous installation is pending. Please restart the system and then rerun Setup.
For more information, visit: http://technet.microsoft.com/library(EXCHG.150)/ms.exch.setupreadiness.RebootPending.aspx

Error:
Setup encountered a problem while validating the state of Active Directory: Couldn’t find the Enterprise Organization container.  See the Exchange setup log for more information on this error.
For more information, visit: http://technet.microsoft.com/library(EXCHG.150)/ms.exch.setupreadiness.AdInitErrorRule.aspx

Warning:
Setup will prepare the organization for Exchange Server 2016 by using ‘Setup /PrepareAD’. No Exchange Server 2013 roles have been detected in this topology. After this operation, you will not be able to install any Exchange Server 2013 roles.
For more information, visit: https://docs.microsoft.com/Exchange/plan-and-deploy/deployment-ref/readiness-checks?view=exchserver-2016

Warning:
Setup will prepare the organization for Exchange Server 2016 by using ‘Setup /PrepareAD’. No Exchange Server 2010 roles have been detected in this topology. After this operation, you will not be able to install any Exchange Server 2010 roles.
For more information, visit: https://docs.microsoft.com/Exchange/plan-and-deploy/deployment-ref/readiness-checks?view=exchserver-2016

image

A reboot from a previous installation is pending. Please restart the system and rerun setup or clear the below attribute and continue

Took backup of the key and Cleared attribute _ PendingFileRenameOperations instead of rebooting the server.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\PendingFileRenameOperations

image

With Exchange 2010 SP3 Setup

.\setup.com /PrepareAD /OrganizationName:”First Organization”

image

Ran Exchange 2016 Setup it worked seamlessly.

image

About Satheshwaran Manoharan

Satheshwaran Manoharan is an Microsoft Office Server and Services MVP , Publisher of Azure365pro.com. Specialized in Office365 / Microsoft Exchange / Virtualization , Sathesh is an Messaging Expert supporting/Designing/Deploying many medium size businesses to large enterprises when it comes to Corporate messaging and Virtualization Infrastructure

Check Also

Some Mails Getting Converted to Chinese Characters

Some Emails in Outlook 2016 will Convert to Chinese Characters after reading some after archiving …

2 comments

  1. I had this exact same error when installing Exchange 2019 on an AD that once contained an Exchange 2007 server. This procedure worked for me. Thanks!

Leave a Reply

Your email address will not be published.